服务器上默认安装版本是:

使用jenkins最新的安装包 2.73.1,启动报错52.0!需要使用1.8进行启动。

两种方式,要么tomcat直接指定,要么修改环境变量,这里我使用修改安装java版本的方法。

 

在服务器上更新了新的 jdk,也在 /etc/profile 中设置了新的 JAVA_HOME,并且 source /etc/profile

然后使用Java -version 和 javac -version 发现版本还是老版本,死活没有使用我新指定的。

中间各种排查,这里就不废话了,下面是文件的根源和解决方法:

使用which java 和 which javac 分别可以看到

[root@localhost ~]# which java
/usr/bin/java
[root@localhost ~]# which javac
/usr/bin/javac

简单说一下,就是把这2个文件ln -s 到我们新的jdk 下的 java 和 javac 上,命令如下:

rm -rf /usr/bin/java

rm -rf /usr/bin/javac

ln -s $JAVA_HOME/bin/javac /usr/bin/javac

ln -s $JAVA_HOME/bin/javac /usr/bin/java

这样执行以后,然后 java -version 、 javac -version